Training, Open Source computer languages
PerlPHPPythonMySQLApache / TomcatTclRubyJavaC and C++LinuxCSS 
Search for:
Home Accessibility Courses Diary The Mouth Forum Resources Site Map About Us Contact
For 2021 - online Python 3 training - see ((here)).

Our plans were to retire in summer 2020 and see the world, but Coronavirus has lead us into a lot of lockdown programming in Python 3 and PHP 7.
We can now offer tailored online training - small groups, real tutors - works really well for groups of 4 to 14 delegates. Anywhere in the world; course language English.

Please ask about private 'maintenance' training for Python 2, Tcl, Perl, PHP, Lua, etc.
loading oratcl from starkit

Posted by sergioanis (sergioanis), 17 March 2008
hi everybody:

I'm having some problems loading oratcl from a starkit. I found a post from G. Lester advicing to use the following script in the package index:

package ifneeded Oratcl 4.4  [ list OraLoad $dir ]
proc OraLoad { dir } {
global env
foreach file [ glob $dir/*.dll ] {
catch {  file copy  -force $file [ file join $env(TEMP) [ file tail $file ]
]  }
catch { file copy  -force $dir/msvcr70.dll [ file join [ file dirname [ infonameofexecutable ]] msvcr70.dll ] }
load $env(TEMP)/oratcl44.dll

This works fine in some computers (running windows 2000), but fail in
anothers (windows 2000 and xp). The script fail when it try to load the
oratcl44.dll, the error message doesn't say why.  I tried adding the
$env(TEMP)to the $env(PATH) without success.

I'd appreciate any suggestions you may have.


Posted by admin (Graham Ellis), 18 March 2008
on 03/17/08 at 18:32:19, sergioanis wrote:
The script fail when it try to load the
oratcl44.dll, the error message doesn't say why.

I'd appreciate any suggestions you may have.

I don't know - and I think this is a very specialist question that's not likely to find and answer here. However, even if you feel that the error message isn't useful, someone might - so please tell us what is says / how it fails.  You're witholding a vital piece of evidence!

Posted by sergioanis (sergioanis), 20 March 2008
the error message says: "error loading oratcl" I tried to put some catch there, but for some reason the catch is ignored (I guess that is another proc generating the error, and I don't have access to it)

Anyway, somebody gave me a hint: the computers where it fails don't have oracle client installed. So, I'm searching for the libraries that I need to add to make it work. So far, I have the oratcl loaded but I can't sign into the database. I just need to keep trying.

thanks for your interest.

This page is a thread posted to the opentalk forum at and archived here for reference. To jump to the archive index please follow this link.

You can Add a comment or ranking to this page

© WELL HOUSE CONSULTANTS LTD., 2022: Well House Manor • 48 Spa Road • Melksham, Wiltshire • United Kingdom • SN12 7NY
PH: 01144 1225 708225 • FAX: 01144 1225 793803 • EMAIL: • WEB: • SKYPE: wellho