Training, Open Source computer languages
PerlPHPPythonMySQLApache / TomcatTclRubyJavaC and C++LinuxCSS 
Search for:
Home Accessibility Courses Diary The Mouth Forum Resources Site Map About Us Contact
 
For 2021 - online Python 3 training - see ((here)).

Our plans were to retire in summer 2020 and see the world, but Coronavirus has lead us into a lot of lockdown programming in Python 3 and PHP 7.
We can now offer tailored online training - small groups, real tutors - works really well for groups of 4 to 14 delegates. Anywhere in the world; course language English.

Please ask about private 'maintenance' training for Python 2, Tcl, Perl, PHP, Lua, etc.
Problem using TclPro,a tcl debugger

Posted by shruthi_21 (shruthi_21), 26 July 2006
I installed TclPro1.4 in my system. The problem is that I have Tcl files which can be executed in my automation framework and all those files have a format which is understandable by that framework.
There are certain procedures present for the framework which are used in the tcl scripts. (say for example, a procedure abc is defined in the source file of the automation framework). Now that I have installed the TclPro inside the framework, when I execute a Tcl script in the debugger, it says that 'abc' is an invalid command since the framework's files are present in a level higher than the debugger.

I want to know how can I execute the debugger with my framework in the global mode. Are there anything that I can do in the TclPro settings?

I would be grateful if someone help me in this......



This page is a thread posted to the opentalk forum at www.opentalk.org.uk and archived here for reference. To jump to the archive index please follow this link.

You can Add a comment or ranking to this page

© WELL HOUSE CONSULTANTS LTD., 2022: Well House Manor • 48 Spa Road • Melksham, Wiltshire • United Kingdom • SN12 7NY
PH: 01144 1225 708225 • FAX: 01144 1225 793803 • EMAIL: info@wellho.net • WEB: http://www.wellho.net • SKYPE: wellho