Training, Open Source computer languages
PerlPHPPythonMySQLApache / TomcatTclRubyJavaC and C++LinuxCSS 
Search for:
Home Accessibility Courses Diary The Mouth Forum Resources Site Map About Us Contact
For 2021 - online Python 3 training - see ((here)).

Our plans were to retire in summer 2020 and see the world, but Coronavirus has lead us into a lot of lockdown programming in Python 3 and PHP 7.
We can now offer tailored online training - small groups, real tutors - works really well for groups of 4 to 14 delegates. Anywhere in the world; course language English.

Please ask about private 'maintenance' training for Python 2, Tcl, Perl, PHP, Lua, etc.
LoG File Error

Posted by ksrra (ksrra), 15 October 2004
I am also new  to the Expect environment  ..
  The purpose of   the script that i have written is to telnet to a switch/router , execute certain commands & capture the logs .

This worked perfectly fine when i ran the script on the router , but on the switch , every thing works fine , but the logs are not created , when i open the log file it gives me either  an error msg saying  "line too large " while opening the   file or the file would contain only  junk characters.Whats going wrong
Any help would be appreciated

thanks in Advance

Posted by admin (Graham Ellis), 15 October 2004
Can you post a few lines of code to illustrate the problem??

Posted by ksrra (ksrra), 15 October 2004

set name [lindex $argv 0]
set user [lindex $argv 1]
set pd [lindex $argv 2]

log_user 1
log_file  -noappend  sw-op

spawn telnet $name

expect    "User ID:"
send $user\n
expect "Enter Password:"
send $pd\n

expect "Next Command:"
send "sh cards"

Posted by admin (Graham Ellis), 15 October 2004
Ah - are you opening the log file in another application and having tgrouble there?  Any chance that you switch is generating new line character delimited responses, and you're opening the log files on a Windows box to look at them?

Posted by ksrra (ksrra), 15 October 2004
S , the switch  does generate the new line character deliminated responses, but  iam not opening in a windows box ,I am  using the ssh shell , I  connect  to the switch &  also  open  the log  file there itself .

Posted by admin (Graham Ellis), 15 October 2004
OK ... if you're getting the problem examining the output after the script has completed on a Linux box (have I understood that right?), then have a look at the output file with something like od that has no ourput line limit.   That way you'll get at least a clue that will point you towards the problem

This page is a thread posted to the opentalk forum at and archived here for reference. To jump to the archive index please follow this link.

You can Add a comment or ranking to this page

© WELL HOUSE CONSULTANTS LTD., 2022: Well House Manor • 48 Spa Road • Melksham, Wiltshire • United Kingdom • SN12 7NY
PH: 01144 1225 708225 • FAX: 01144 1225 793803 • EMAIL: • WEB: • SKYPE: wellho