Training, Open Source computer languages
PerlPHPPythonMySQLApache / TomcatTclRubyJavaC and C++LinuxCSS 
Search for:
Home Accessibility Courses Diary The Mouth Forum Resources Site Map About Us Contact
Issues about running tcl scripts as a testsuite

Posted by sonali.birari (sonali.birari), 14 December 2006
I need to do following thing:

I have 1 tcl script - prereq.tcl (kind of prerequisites, say create user1).

I need to load this before test execution begins.

I have 3 testfiles : testfile1, testfile2,testfile3

each test file looks like this:
testfile1:
...
source prereq.tcl
...
...test code goes here...
....

This way I can execute each testfile independently.

But If I have to run these 3 testfiles in a suite, the tcl script-prereq.tcl will get loaded in each of the testfile execution i.e.
it will create user 3 times.

What my requirement is that:
In the suite, it should first check, if user USER1 is already present. IF yes, then it should skip the 'creation of user part'.

Hope my problem is clear.

Pl provide information

Regards,
Sonali



This page is a thread posted to the opentalk forum at www.opentalk.org.uk and archived here for reference. To jump to the archive index please follow this link.

You can Add a comment or ranking to this page

© WELL HOUSE CONSULTANTS LTD., 2014: Well House Manor • 48 Spa Road • Melksham, Wiltshire • United Kingdom • SN12 7NY
PH: 01144 1225 708225 • FAX: 01144 1225 899360 • EMAIL: info@wellho.net • WEB: http://www.wellho.net • SKYPE: wellho