Training, Open Source computer languages
PerlPHPPythonMySQLApache / TomcatTclRubyJavaC and C++LinuxCSS 
Search for:
Home Accessibility Courses Diary The Mouth Forum Resources Site Map About Us Contact
 
For 2021 - online Python 3 training - see ((here)).

Our plans were to retire in summer 2020 and see the world, but Coronavirus has lead us into a lot of lockdown programming in Python 3 and PHP 7.
We can now offer tailored online training - small groups, real tutors - works really well for groups of 4 to 14 delegates. Anywhere in the world; course language English.

Please ask about private 'maintenance' training for Python 2, Tcl, Perl, PHP, Lua, etc.
Integrating Tcl/Tk with C/C++

Posted by smcool89 (smcool89), 13 November 2007
Hello  
I am new to tcl and to this forum also.
I saw this forum i found that i found that the error mentioned in the questions from the man are exactly the  same as mine..
I have a small program written in c interacting with tcl and i don't know how to compile and use it .. I have tried several ways mentioned at different places and have got some errors .. below is the code and the errors i got while compiling it..
the code i am compiling :

#include <stdio.h>
#include <tcl.h>

main (int argc, char *argv[]) {

       Tcl_Interp *myinterp;
       int status;

       printf ("Your Tcl Program will run ... \n");

       myinterp = Tcl_CreateInterp();
       status = Tcl_EvalFile(myinterp,argv[1]);

       printf ("Your Tcl Program has completed\n");
}


The error i am getting :
I tried with the following way and got some error.. can't figure it out what is this ...  
[sam@sam learning_c++]$ g++ c_tcl7.c -ltcl
/usr/bin/ld: cannot find -ltcl
collect2: ld returned 1 exit status

then i tried with this simple way and got some error and still can't find it out what is the problem behind that:
[sam@sam learning_c++]$ g++ c_tcl7.c
/tmp/ccgOFffj.o(.text+0x2d): In function `main':
: undefined reference to `Tcl_CreateInterp'
/tmp/ccgOFffj.o(.text+0x43): In function `main':
: undefined reference to `Tcl_EvalFile'
collect2: ld returned 1 exit status

Please help me....

Posted by admin (Graham Ellis), 13 November 2007
You've not got your Tcl library and header files installed on your gcc path. Have a look at the library and include pasth options for gcc, and add extra parameters to your gcc to reflecttheir location.

Posted by admin (Graham Ellis), 26 November 2007
Poster has email me to let me know "problem solved" .... should have been using

-ltcl8.4



This page is a thread posted to the opentalk forum at www.opentalk.org.uk and archived here for reference. To jump to the archive index please follow this link.

You can Add a comment or ranking to this page

© WELL HOUSE CONSULTANTS LTD., 2022: Well House Manor • 48 Spa Road • Melksham, Wiltshire • United Kingdom • SN12 7NY
PH: 01144 1225 708225 • FAX: 01144 1225 793803 • EMAIL: info@wellho.net • WEB: http://www.wellho.net • SKYPE: wellho