Training, Open Source computer languages
PerlPHPPythonMySQLApache / TomcatTclRubyJavaC and C++LinuxCSS 
Search for:
Home Accessibility Courses Diary The Mouth Forum Resources Site Map About Us Contact
For 2023 (and 2024 ...) - we are now fully retired from IT training.
We have made many, many friends over 25 years of teaching about Python, Tcl, Perl, PHP, Lua, Java, C and C++ - and MySQL, Linux and Solaris/SunOS too. Our training notes are now very much out of date, but due to upward compatability most of our examples remain operational and even relevant ad you are welcome to make us if them "as seen" and at your own risk.

Lisa and I (Graham) now live in what was our training centre in Melksham - happy to meet with former delegates here - but do check ahead before coming round. We are far from inactive - rather, enjoying the times that we are retired but still healthy enough in mind and body to be active!

I am also active in many other area and still look after a lot of web sites - you can find an index ((here))
SSI inside an SSI

Posted by TedH (TedH), 10 January 2006
Hi, messing about with server side includes.

I call a text file into the html page (include virtual="file.txt"). In file.txt is another include (include virtual="filenav.txt"). Now this works fine on my localhost testbed server (Indigo Perl/Apache), but when I try it on my live Apache webserver the second include does not show.

I was a bit surprised it worked in the first place locally - which is why I tried it on the live server.

Any thoughts on that? Just would make things a whole bunch (like lotsa) easier if it worked.

- Ted

Posted by TedH (TedH), 12 January 2006
Forgot about my conf file - didn't I  

At first I thought that didn't go, but did a little trick to overide my ISP's caching (NTL have done something weird to their servers in the past week or so).

Must've have been those mince pies at Christmas.... finally kicked in.

Posted by admin (Graham Ellis), 12 January 2006
Gosh ... didn't notice you post last night, Ted - sorry about that .... but you're sorted now, right?

It's been a really weird day here ... can't take too many more with such huge highs and lows. And tomorrow's Friday the 13th!

Posted by TedH (TedH), 12 January 2006
Hi Graham, sounds as though you need a really nice port in front of a open fire and just stare into the flames for a bit.


This might help those of you who have caching problems with hosts or ISPs.

The problem: You've updated a page and the update doesn't show. It can take hours in some cases for it to happen. This is because ISP servers cache your surfing to "speed" things up a bit. It seems to me to be a false "speed" thing. It is also frustrating and annoying if you are a developer.

The solution: If you find an update does not show, do this. Type in your URL ...

The ? has to be there, "anything" can be after. What it does is fool the server into thinking you are going to a different URL - and your update shows.

Don't use the same "anything" twice in a row. You can use ?abc or ?grahamneedsabreak or whatever just as long as the question mark precedes it.

- Ted

This page is a thread posted to the opentalk forum at and archived here for reference. To jump to the archive index please follow this link.

You can Add a comment or ranking to this page

© WELL HOUSE CONSULTANTS LTD., 2024: Well House Manor • 48 Spa Road • Melksham, Wiltshire • United Kingdom • SN12 7NY
PH: 01144 1225 708225 • FAX: 01144 1225 793803 • EMAIL: • WEB: • SKYPE: wellho