Training, Open Source computer languages
PerlPHPPythonMySQLApache / TomcatTclRubyJavaC and C++LinuxCSS 
Search for:
Home Accessibility Courses Diary The Mouth Forum Resources Site Map About Us Contact
MCpan error

Posted by pfo (pfo), 1 October 2004
Hi

when I launch MCPAN
[root@server1]# perl -MCPAN -e shell

I have this error :
Undefined value assigned to typeglob at (eval 14) line 15, <RC> line 11.
Warning [/etc/inputrc line 11]:
 Invalid variable `mark-symlinked-directories'

cpan shell -- CPAN exploration and modules installation (v1.76)
ReadLine support enabled

Now I can't install perl pgm

The only things I've done is to install the last MCPAN bundle

Do you have any idea ?

Thanks for your help

Pfo

Posted by admin (Graham Ellis), 1 October 2004
Oh goodness - just saying "welcome" but I've no obvious answer ... I hope someone like jpf of custard may come up with something??  I'm out of my office (away from good connectiviity) until later in the weekend ... please do post a follow up on Saturday or Sunday night if this is still unresolved and I'll see if I can at least find something a little more to help.

Posted by Custard (Custard), 1 October 2004
Indeed.

From the CPAN.pm perldoc


When I run CPAN's shell, I get error msg about line 1 to 4,
setting meta input/output via the /etc/inputrc file.

"
Some versions of readline are picky about capitalization in the
/etc/inputrc file and specifically RedHat 6.2 comes with a
/etc/inputrc that contains the word on in lowercase. Change the
occurrences of 'on' to 'On' and the bug should disappear.
"

This may not be your error, but may be a place to look.
What version of Perl are you using (perl -v)
And what OS (uname -a)

Bruce

Posted by pfo (pfo), 1 October 2004
Hello

and thank you for your help

Perl : 5.8
Os : CentOS 3.1

I have comented out the line 'mark-sumlinked-directories' in inputrc, and I don't have any more error.

But I think I didn't resolve the pbm as I have a lot of pbm trying to install modules

ie : pod2man not find.

I have pod2man in /bin/

Thanks for your help

Pfo

Posted by Custard (Custard), 1 October 2004
Hi,

Getting closer then..

Which Perl 5.8  (there are six from 5.8.0 to 5.8.5)

CentOs 3.1... That'll be a RedHat Linux derivative then..

Unfortunately I have no Linux systems to play on here, only Solaris and Darwin, and neither has an /etc/inputrc so it's tricky to be able to help you further.

However, a bit of a google, and I found this.. (your error?)

http://www.redhat.com/archives/redhat-list/2003-April/msg00224.html

So, you're not alone..

Can you post the mark-symlinked-directories line here?
And check that the first letter of On or Off is capitalised.
And for that matter, that the other On's and Offs are also first letter capital.

And FYI,

http://www.die.net/doc/linux/man/man3/readline.3.html

Having read what readline does again,
I don't think it has anything to do with your second problem.
Must be something to do with PATH or the location of pod2man.
If it's the perl that came with the OS, it may only have had the perl binary installed.  
Maybe you should install a new version of perl (like 5.8.5) in /usr/local and use that (while leaving the existing perl alone)
I find I have to do this on Solaris systems which come with a positively ancient perl 5.5.3.

B

Posted by pfo (pfo), 1 October 2004
Ok a great thanks to you.

I'm happy to know that I'm not alone (I found same error on google in a russian forum, but I don't read russian :\ )

Well here is the beginning of the inputrc
Code:
# do not bell on tab-completion
#set bell-style none

set meta-flag on
set input-meta on
set convert-meta off
set output-meta on

# Completed names which are symbolic links to
# directories have a slash appended.
#set mark-symlinked-directories on

$if mode=emacs



I have comented out the line 11 (#set mark-symlinked-directories on)

I tried to change all on and off to On and Off but same pbm.

Ok, I'll upgarde my perl and come back to tell you if it's better

Thanks for your help

pfo


Posted by Custard (Custard), 2 October 2004
Well, don't do it if you don't have to.

Check that pod2man etc are on the path first, and if not, find them and set the PATH accordingly.

Try
which pod2man
and
echo $PATH
to see what's going on..

B

Posted by pfo (pfo), 2 October 2004
ok

[root@server1 root]# which pod2man
/bin/pod2man
[root@server1 root]# echo $PATH
/usr/kerberos/sbin:/usr/kerberos/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/usr/bin/X11:/usr/X11R6/bin:/root/bin


Well it seems to be fine

But I always have my pbm in CPAN and trying install module (perl -v = 5.8.0 which is not the last one but not an old one)

I really don't know what is going on

Thanks

Posted by Custard (Custard), 2 October 2004
Thanks.

It's on the path, as you say.

I'm not sure what's going on here either.  

At what point does the module install fail?
Can you cut & paste the last 30 or so lines from the screen to here.

It could be that it (Perl & CPAN) is looking for things in a different location.
When a Perl installation is compiled, you specify where it will live, and what paths lead to the libraries etc. This is compiled into the perl binary. If you then change the location of the binary (from /usr/local/bin to /bin say) then it will still expect to find libraries etc in /usr/local.
Although I have to admit that I don't think it cares where the other binaries are found.

Hmm curious.  Did you install perl, and if so, from a binary distrubution or did you compile it.  Or was it on the system already?

If the system isn't a live system, and you're happy, you could try a fresh install, and specify somewhere safe like /usr/local
I'm sometimes dubious of pre-installed perls as occasionally they are not complete.

You could do a perl -V  (capital V) and see where it thinks it should be.

Other than that, I think I have come to the end of all the steps I would take in this process.

Good luck.  (May the source be with you!

B



This page is a thread posted to the opentalk forum at www.opentalk.org.uk and archived here for reference. To jump to the archive index please follow this link.

You can Add a comment or ranking to this page

© WELL HOUSE CONSULTANTS LTD., 2014: Well House Manor • 48 Spa Road • Melksham, Wiltshire • United Kingdom • SN12 7NY
PH: 01144 1225 708225 • FAX: 01144 1225 899360 • EMAIL: info@wellho.net • WEB: http://www.wellho.net • SKYPE: wellho