Training, Open Source computer languages
PerlPHPPythonMySQLApache / TomcatTclRubyJavaC and C++LinuxCSS 
Search for:
Home Accessibility Courses Diary The Mouth Forum Resources Site Map About Us Contact
executing package not working

Posted by pagalreddy (pagalreddy), 12 October 2005
$GOrgID = $_SESSION['OrgID'];
      $curs = ocinewcursor($link);
     $query = OCIParse($link,"BEGIN PKG_CMT_PROCS.GetOrgDetails(:GOrgID,:po_refcur);END;");
OCIbindByName($query, ":GOrgID", &$GOrgID,1);
OCIbindByName($query, ":po_refcur", &$curs, -1, OCI_B_CURSOR);
$result = ociexecute($query);//for this organisation
           ociexecute($curs);

     if ($query)  //If no data            
     {
// ============================for every piece of data ...
           while (ocifetchinto($curs,&$po_refcur))
           {
$PropertyName = ociresult ($curs,"DetailName");
$PropertyValue = ociresult($curs,"DetailValue");
$name = "G".$PropertyName;
$_SESSION[$name] = $PropertyValue;
           }
             
             
     }

Please do help me out if fixing the Cdatabaseowner in my previous problem and also let me know where and what IAm doing wrong ?

Posted by admin (Graham Ellis), 13 October 2005
on 10/12/05 at 17:19:56, pagalreddy wrote:
... in my previous problem ....


If you have any follow up problems, it would be a great help if you can post them in the same thread.  That way, we'll understand better what you're referring to.



This page is a thread posted to the opentalk forum at www.opentalk.org.uk and archived here for reference. To jump to the archive index please follow this link.

You can Add a comment or ranking to this page

© WELL HOUSE CONSULTANTS LTD., 2014: Well House Manor • 48 Spa Road • Melksham, Wiltshire • United Kingdom • SN12 7NY
PH: 01144 1225 708225 • FAX: 01144 1225 899360 • EMAIL: info@wellho.net • WEB: http://www.wellho.net • SKYPE: wellho