Training, Open Source computer languages
PerlPHPPythonMySQLApache / TomcatTclRubyJavaC and C++LinuxCSS 
Search for:
Home Accessibility Courses Diary The Mouth Forum Resources Site Map About Us Contact
missing and corrupt files since cron backup script

Posted by dabbler (leah), 13 March 2004
About 10 days ago I started running automatic backups of the cgi directories (for forums) on two websites. I created a simple script with a tar command, and am running that script once a day via cron.

Two things have happened in the last two days that are very odd. Yesterday, a users data file became empty. It was still there, but blank. This morning, on another server, two files have gone missing from another yabb directory. They were in the backups, but I'm worried what else is going to disappear.

I can only imagine that this might have something to do with the backup scripts? I would doubt it to be a sudden coincidence when this hasn't happened ever before.

In root, .backup contains:
Code:
tar -cpzf ./pathtobackups/backup_`date +%d%m%y`.tar.gz ./cgi-bin


Posted by admin (Graham Ellis), 14 March 2004
I would stongly take the view that the crontab job / tar isn't what did the damage ... I have some alternative thoughts, which I'll let you know by p.m. or email .... I would feel a bit funny describing server security issues in detail here in case I gave some clues away

Posted by dabbler (leah), 14 March 2004
Thanks Graham.

Edit:Maybe this thread should be retitled to cron backups in the nick of time.



This page is a thread posted to the opentalk forum at www.opentalk.org.uk and archived here for reference. To jump to the archive index please follow this link.

You can Add a comment or ranking to this page

© WELL HOUSE CONSULTANTS LTD., 2014: Well House Manor • 48 Spa Road • Melksham, Wiltshire • United Kingdom • SN12 7NY
PH: 01144 1225 708225 • FAX: 01144 1225 899360 • EMAIL: info@wellho.net • WEB: http://www.wellho.net • SKYPE: wellho